Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PPM only loading (at main) if logged on as Sysadmin
#1
Noble other RPro-ers,

Has anyone ever experienced an issue with PPM and security rights?

I realized we had no R symbol in the systray of the Mothership machine, and went to ws prefs to see what was up. I am the alpha geek here, so I have all permissions as an administrator.

All EFT options were greyed out. When I logged in as Sysadmin, the ws prefs page was enabled and I was able to click "PPM runs on this server", and get the credit card dialage back. I logged out, back to my usual personality, and the EFT options greyed out again. I made up a new personality as a power user/admin, saved it, registered Rpeo8.sec, saved, rebooted.

Restarted Rpro with new personality; still no ppm ability.

The only thing that has changed recently is a) upgraded from 8.51 to 8.52, and b) been mucking with an evening backup.bat that has a taskkill line for shutting down the im ppmsrvr.exe.

Any thoughts? Does something need to be re-indexed? RProDB'd?

Thanks in advance,

Barbara Ann
Reply
#2
It is not unusual for security rights to change after installing an update.
After installing an update, you should go into Sec Admin (when people are out of Rpro) and Click File > Register Security information and look for rpro8.sec and double-click. In this case you will also want to follow these same steps and double-click Batch.sec. Then click on the Administrators group and you will see that some things are no longer checked. You will want to check any rights you want Administrators to have.

Pay attention to what you have to re-check for Administrators because you will need to click on each Group that you are using and check off those same rights, as appropriate.
Reply
#3
Thank you Donna!

The setting that made the difference was under RProSystemEFT-Modify EFT Config. I only had to change it under Administrators (in both RPRO8.sec and batch.sec, just to make sure), and it now allows POS folk who start the main to get PPM running. The settings under EFT were already correct for my purposes.

Thanks for the hint!

Barbara Ann
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)